CentOS启动出现Failed to start LSB: Bring up/down networking的解决方法

网络  时间:2021-04-25  阅读:()

在一台物理服务器上遇到这个问题,为了避免忘记所以记录下,方便下次再有这种情况自己搜索。涉事独立服务器所安装的操作系统为centos7.*,无缘无故断网了,通过KVM登录进去重启网络也卡死,重启操作系统就发现启动中有如标题的提示,如下图:

A start job is running for LSB: Bring up/down networking(**s / 5min 5s)

这个过程要等到5min 5s到了才会结束,然后报失败:Failed to start LSB: Bring up/down networking

网络上一般有两处解决方案,其中之一是禁用NetworkManager,我处理后网络恢复,执行命令:

systemctl stop NetworkManagersystemctl disable NetworkManagersystemctl restart network

另外一种说法是需要在网络配置文件中加入MAC地址:

HWADDR=**:**:**:**.** (可以通过ip addr命令查看)

不过,虽然我通过禁用NetworkManager恢复了网络,但是服务器重启后又一样,需要再次操作,不清楚为什么,有遇到这种问题彻底解决的朋友欢迎分享,我的解决方式简单粗暴:网络恢复后备份数据到异地,直接全格重装,OK了。

为你推荐
免费PuTTY SSH工具下载及对比XShell哪个更好Vultr服务器日本机房去程/回程路由及速度测试(非CN2直连线路)Novos:€8/月KVM-2GB/40G NVMe+1TB/25TB/比利时关于常见 .COM, .ORG, .NET, .BIZ, .CO 域名后缀由来和应用10g.biz-洛杉矶CN2 GIA服务器低价促销,VPS低至$3.58/月,不限流量200M 独立服务器低至$97.3/月edgeNAT牛年春节活动汇总 – 全场六折 香港/韩国/美国CN2 VPS主机茶猫云-香港沙田CN2、大浦GIA,高I/O,首月仅9.9元,采用KVM架构及HYPER-V两个地区Newcloud-香港服务器新年钜惠,迎新春年末促销,三网回国独服优惠后仅$54.50,终身优惠码newcloudDigital-vm全场VPS六五折$2.6/月起,1-10Gbps带宽,KVM架构,美国/日本/新加坡等8机房Digital VM 新增二月六五折优惠 8个数据中心 季付7美元
网络调研公司有哪些 网络文化经营许可证 免费外国网络服务器 已丢失网络连接什么意思 网络名称是什么意思 网络诊断 网络会议平台排名 网络安全公司排名 智能无线网络摄像头 网络协议主要要素为 网络用语oc是什么意思 虚拟网络 网络调研 计算机网络安全 软考网络工程师 福建广电网络 网络加速器外网 网络环境 网络安全专业学校排名 计算机网络的主要功能 更多