disrupt免费dns
免费dns 时间:2021-04-20 阅读:(
)
1464XLAT:BreakingFreeofIPv4Cameron.
Byrne@T-Mobile.
comAPRICOT2014BackgroundT-MobileUSisaGSM/UMTS/LTEproviderintheUSAwith45+MillionsubscribersIn2008,T-MobilelaunchedthefirstAndroidphone.
Thisdramaticallychangedthemobiledatadynamics–moredevices,connectedforalongertime,allneedingIPaddressesT-MobileembracedtheconceptofIPv6-only,sincedual-stackrequiredIPv4thatwasnotavailableNAT64/DNS64wasagoodsolutionthatdidnotrequireIPv4oneachclient,butsomeapplicationsfailedtoworkonIPv6-onlynetworks.
ItisnotacceptabletobreakSkypeorNetflix,applicationsthatrequireIPv4T-Mobile,inpartnershipwithNECandJPIX,documented464XLATintheIETFasRFC6877toovercomethelimitationsofNAT64byaddingaNAT46intotheclient(CLAT)Android4.
3introducedsupportfor464XLATinOctober20132ResultsAreImportantT-MobileUSlaunched5Androidphoneswith464XLATasthedefaultinthelast5months,allAndroid4.
3+phoneswillbe464XLATinthefutureatT-MobileUS3.
6millionuniqueIPv6subscribersinthefirst5monthsareactiveonthenetworkhttp://www.
worldipv6launch.
org/measurements/measurementsshow15.
76%ofallT-MobileconnectionsarenowIPv6,asofFebruary21,2014Over50%ofIPv6-usertrafficisend-to-endIPv6(notranslationneeded)Thissavesmoneyandmakesthenetworksimpler315.
76ofT-MobileUSConnectionsuse464XLAT4Default464XLATPhonesatT-MobileUS5SamsungNote3Google/LGNexus5SamsungMega464XLATPhones6SonyZ1sGalaxyLight464XLATallowsforfullfunctionalityonIPv6-onlynetworksDual-stackdoesnotsolvetheIPv4numberscarcityissueIPv6-only+NAT64/DNS64isverygood,butnotgoodenoughforfullIPv4replacement(webandemailwork,butSkypedoesnotwork)IPv6-only+464XLATSolvesIPv4numberingissuebynotassigningIPv4toclientsDecouplesedgegrowthfromIPv4availabilityIPv4-onlyapplicationslikeSkypeworkonanIPv6-onlynetworkbecause464XLATtranslatesIPv4onthephonetoIPv6onthenetwork7IPv6deploymentiseasyachievableT-MobileUSAdidnotspendanyCapExonIPv6Onlyintroduce464XLATonnewphones,sowedonotdisruptanyexistingservicesInnovativethinkinghelpsreducedeploymentcosts(hash128bitnumbersinto32bitfieldsinbillingrecords)IPv6willsavemoneyinyournetwork(lessNAT/CGN,noneedtobuyIPv4addresses,…)8Infact,withroaming,wecanshowChunghwainTaiwanandMYMAXISinMalaysiasupportIPv6todayintheRadioAccessNetwork(RAN)9WhichPlatformsSupports464XLATTodayYESAndroid4.
3+NOBlackberryAppleWindowsPhone()10IMPORTANT!
AnythingthatisnativelyIPv6enableddoesnotrequireanysortoftranslation,464XLATisidleandtransparentforanyIPv6end-to-endflowIPv6end-to-endjustworks!
464XLATisonlyforserviceandapplicationsthatareusingLEGACYIPV4AsmoreandmoreservicestransitiontoIPv6,464XLATisengagedlessandless464XLATisanIPv4EXITSTRATEGY11THETECHNICALDETAILS12464XLATisjustasetofbuildingblocksStatelessNAT64(RFC6145)ClientsidetranslationCLATStatefullNAT64(RFC6146)ProvidersitetranslationPLATDNS64(RFC6147)WhentheFQDNdoesnothaveaAAAArecord,DNS64dynamicallycreatesonethatallowstheclienttouseIPv6andthenetworktranslatesfromIPv6toIPv4attheNAT64Prefix64Discovery(RFC7050)Queriesforthewell-knownFQDNipv4only.
arpa,whichisbydefinitionIPv4-only.
IfthereisaAAAAresponseprovided,thenitisknownthataDNS64isinthepath133Scenariosin464XLAT1.
End-to-endIPv6:Facebook,Google,Wikipedia,Yahoo,Youtube…IPv6->IPv62.
ApplicationsupportsIPv6(webbrowser)buttheserverisonlyIPv4(www.
amazon.
com,www.
myspace.
com,…),soDNS64/NAT64translatesIPv6->IPv43.
ApplicationdoesnotsupportIPv6(Skype,Whatsapp,…),theclientmustprovideastatelessNAT46totheapplicationandstatefulNAT64mustbeinthenetwork:IPv4->IPv6->IPv414HowdoesStatelessNAT64workAlgorithmicallymapIPv4addressestoIPv6addresses,bidirectional,1to1NotdynamicDeterministicMapsallofIPv4's32bitsintoanIPv6/96(orlargerprefix)DefinedinRFC6145Example2001:db8::10.
1.
1.
110.
1.
1.
12001:db8::10.
2.
2.
210.
2.
2.
22001:db8::www.
example.
comipv4www.
example.
com15HowdoesStatefulNAT64work16DynamicallytranslateIPv6packetstoIPv4packetsDynamicNotdeterministic(translationbasedonavailableIPv4pool)Translationstateisshort-livedandbasedonsessioncreationandterminationDefinedinRFC6146ExampleBeforetranslationTCPsource2001:db8:abcd::ffffport555#clientaddressTCPdestination2001:db8:1234::10.
1.
1.
1port80#NAT64addressAftertranslationTCPsource192.
168.
1.
1port555#192.
168.
1.
1availablefromNAT64poolTCPdestination10.
1.
1.
1port80#Last32bitsofIPv6destinationHowdoesDNS64workWhenanFQDNdoesnothaveaAAAArecord,theDNS64willsyntheticallycreateonebasedonanetworkdefinedPref64Thepref64isaprefixhostedontheNAT64fortranslationExamplewithoutDNS64Query=aandaaaaforwww.
example.
comAnswer=a=10.
1.
1.
1,aaaa=NOERRORExamplewithDNS64Query=aandaaaaforwww.
example.
comAnswer=a=10.
1.
1.
1ANDaaaa=2001:db8::10.
1.
1.
117HowisthePref64discoveredontheclientPref64istopologicallylocatedontheNAT64TheDNS64forcesclientstosendtraffictotheNAT64fortranslationfromIPv6toIPv4AutomaticdiscoveryofPref64isdefinedinRFC7050Theclientwilllookupthewell-knownFQDNipv4only.
arpa.
IfaAAAArecordispresentedforthiswell-knowIPv4-onlyFQDN,theclientcanparsetheresponsetofindthePref64usedwithinthisnetwork18Pref64ConfigurationInformationFlow19HowtomakeEVERYTHINGworkonIPv6-only20ZoomOut:Whatdoesthislooklikeinthecontextof3GPPGSM/UMTS/LTE21HighLevelViewofIPv6deployment:Phone,HLRprofile,GGSN,NAT64,IPv6ISP2223ImpacttoNetworkEntitiesImpacttoNetworkEntitiesZoomin:WhatdoesthedefaultAndroidconfigurationlooklike:clatd.
conf24Zoomin:Whatdoesthephoneconfigurationlooklike:APNSettings25InAndroid4.
3,"APNProtocolIPv6"forthe"APNTypedefault"triggerstheuseof464XLATbydefaultIPv6=464XLATTIMEFORWIRESHARK26Likemostthings,westartwithDNSTheclientisIPv6-onlytowardsthenetwork,butthehostOSthinksitisdual-stacksinceithasanIPv4CLATinterfaceandanativeIPv6radiointerfaceSo,theclientdoesaqueryforDNS"A"and"AAAA"recordsTheDNS64respondswithasynthesizedAAAAandtherealAThesynthesizedAAAA=Pref64+realIPv427QuickCheckDoesthesynthesizedAAAAmatchthepref64+realA28pref64RealIPv4Next,theUEselectstheIPv6DNSresponse,andstartsTCPFromtheclientperspective,thisisanativeIPv6end-to-endflowBut,weknowthattheDNSisasynthesizedAAAAandtheclientisactuallysendingitspacketstotheNAT64forIPv6->IPv4statefultranslationThisisjustDNS64/NAT64,noclient-sidetranslationneededforthisscenario29Thefullcaseof464XLATdoubletranslation:WhatsApp30SYNissentfromtheCLATaddress31Remember,wesettheclatd.
conftousetheIIDof::464forCLATtranslationsTheMMSsituationTheAndroidMMSfunctioncommunicatesdirectlytothemodemandby-passesthenormalOSnetworkingstackFrequentlyMMSisitsownAPNThismeans464XLATisbypassed,464XLATonlyworksonthedefaultAPN,notspecialAPNslikeSUPLandMMSSolutionsUseanFQDN,DNS64stillworksfineIfyoucannotuseanFQDN,manuallyuseaNAT64literalinsteadoftheIPv4literal(pref64+ipv4literal)32Security:FollowtheruleofleastprivilegeFilteraccesstotheDNSseverFilteraccesstothePref64ontheNAT64UsingULAPref64willNOTworkwellsinceAndroidprefersIPv4overIPv6ULA.
Thisresultsin100%CLATtranslationsforIPv4resources33SummaryIPv4doesnotfitthebusinessneedstogrowtheedgeofournetworksfueledbygrowthfrominternetofthingsandcloudIPv6workstodayandisdeployedonsomeofthelargestedgenetworks464XLATallowsnetworkstogrowwithoutmanypublicIPv4addressesIPv6deploymentin3GPPGSM/UMTS/LTEisachievabletoday34BigPicture:WemustavoidtheInternet'slargestgrowthengine(mobile)frombeingindefinitelytiedtoscarceIPv4andfragilestatefulNAT44.
WebHorizon是一家去年成立的国外VPS主机商,印度注册,提供虚拟主机和VPS产品,其中VPS包括OpenVZ和KVM架构,有独立IP也有共享IP,数据中心包括美国、波兰、日本、新加坡等(共享IP主机可选机房更多)。目前商家对日本VPS提供一个8折优惠码,优惠后最低款OpenVZ套餐年付10.56美元起。OpenVZCPU:1core内存:256MB硬盘:5G NVMe流量:200GB/1G...
Virmach自上次推出了短租30天的VPS后,也就是月抛型vps,到期不能续费,直接终止服务。此次又推出为期6个月的月抛VPS,可选圣何塞和水牛城机房,适合短期有需求的用户,有兴趣的可以关注一下。VirMach是一家创办于2014年的美国商家,支持支付宝、PayPal等方式,是一家主营廉价便宜VPS服务器的品牌,隶属于Virtual Machine Solutions LLC旗下!在廉价便宜美国...
totyun,新公司,主要运作香港vps、日本vps业务,接入cn2网络,不限制流量!VPS基于KVM虚拟,采用系统盘和数据盘分离,从4G内存开始支持Windows系统...大家注意下,网络分“Premium China”、“Global”,由于站长尚未测试,所以也还不清楚情况,有喜欢吃螃蟹的尝试过不妨告诉下站长。官方网站:https://totyun.com一次性5折优惠码:X4QTYVNB3P...
免费dns为你推荐
中国在线代理配置用于Windows操作http企业cms企业站cms哪个好支付宝蜻蜓发布刷脸支付加盟,支付宝蜻蜓刷脸设备出后,微信也出了青蛙刷脸设备,感觉很有前景,大伙觉得呢?googlepr百度权重和googlePR都是些什么东西??cisco2960配置cisco4506与2960的vlan配置开心001开心001与开心网怎么不一样,哪个是真的?银花珠树晓来看用黄皮比喻心酸的诗句什么是通配符什么是直女癌?
郑州虚拟主机 vps是什么 godaddy域名解析教程 新秒杀 vmsnap3 老左博客 表单样式 线路工具 绍兴高防 静态空间 河南移动m值兑换 超级服务器 四川电信商城 上海电信测速网站 lamp怎么读 lamp的音标 贵州电信 xshell5注册码 香港ip privatetracker 更多